Discuss Plumbing and Heating: glow worm ultracom 18hxi low flame problem in the Plumbing and Heating Forum area at TilersForums.com

The Wetroom Store - TilersForums.com Sponsor
This official sponsor may provide discounts for members

Plumbing News

TF Official Sponsor
Premium
Joined
Dec 9, 2019
Messages
2,223
glow worm ultracom 18hxi low flame problem plumbing question
hi, Im looking at a glow worm ultracom 18hxi that heats up to mid 70s/80s works for about 20 mins, then goes into low gas mode (one flame on display) and stays there for the rest of time. no heat in the water or rads.
I have changed a 3 way valve (which was jammed with the black stuff)
I then changed the pump (whos impeller fell apart when took head off)
the pump then started sucking air into system so turned it to low setting, worked ok for a day, then problem started again.
they tell me that they had it flushed a few months ago and a magna clean fitted.
if i reset it a few times it starts working fine?
im thinking pcb now, any ideas?

glow worm ultracom 18hxi low flame problem

This has been posted to our plumbing forum, click glow worm ultracom 18hxi low flame problem to reply to this plumbing question.
 

Reply to Plumbing and Heating: glow worm ultracom 18hxi low flame problem in the Plumbing and Heating Forum area at TilersForums.com

New Threads (Sitewide)

Top Bottom
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock
No Thanks

Use TilersForums.com to find Tiling Jobs or your Local Tilers for free. Get tiling tools at the best prices via the forum.