Discuss Heatmiser UH8-RF Control Unit - No Hot Water Light in the Tiling over Electric Underfloor Heating area at TilersForums.com

G

gmas2001

TF
Joined
Mar 22, 2018
Messages
2
Location
surrey
Hi Guys,

I have a Heatmiser UH-8 RF control unit for my underfloor heating system downstairs and it's been working fine for over 2 years. Since yesterday however the HW (Hot Water) light isn't coming on, can anyone help me with this? The room controllers are working fine and talking to the control unit but no HW light.

Cheers.

uh8.JPG
 
Uheat - Jake

Uheat - Jake

TF
TF Official Sponsor
Joined
Aug 26, 2016
Messages
127
Reactions
147 1
Your best bet is to call Heatmiser Technical team, they'd be able to talk you through troubleshooting if the connections dropped or if the unit could be faulty.
 
Wayne Brown

Wayne Brown

TF
Esteemed
Arms
Joined
Dec 2, 2018
Messages
262
Reactions
209 1
Location
Norfolk
I would get a electrician to check it out, I see this is a rf unit the thermostats often rely on batteries please check if they need changing ? Not sure how the hot water wiring is configured post a picture of your hot water cylinder cheers kop
 
A

Ajax123

TF
Supporter
Arms
Joined
Apr 2, 2009
Messages
5,641
Reactions
862 6
Location
Lincolnshire
I would check if you are getting hit water. If you are it's just a led failed. If its not then get a nan in to check it out.
 

Reply to Heatmiser UH8-RF Control Unit - No Hot Water Light in the Tiling over Electric Underfloor Heating area at TilersForums.com

New Threads (Sitewide)

Top Bottom

Use TilersForums.com to find Tiling Jobs or your Local Tilers for free. Get tiling tools at the best prices via the forum.